viernes, 3 de abril de 2015

Repositorios no oficiales para Fedora

 Los usuarios de Linux en general han de saber que para poder instalar alguna aplicación, antes es necesario que dicha aplicación esté en los repositorios oficiales de la distribución que estén usando.
Excepto aquellas que las descarguen de manera externa con la extensión oficial de la distro usada.

Para todos los demás casos, es necesario agregar el repositorio para una instalación más cómoda.
La ventaja principal de utilizar repositorios oficiales para una distro Linux, es que provee actualizaciones constantes, incluso permite o informa de software en desarrollo como versiones alpha o beta.

En multitud de ocasiones es necesario buscar y agregar los repositorios por separado, así que me dado a la tarea de reunir algunos repositorio más usuales como los que se muestran la siguiente lista:
  1. VirualBox
  2. GoogleChrome
  3. MySQL
  4. Geogebra
  5. Dropbox
  6. Rpmfusion-free-updates
  7. Rpmfusion-free-updates-testing
  8. Rpmfusion-nonfree
  9. Rpmfusion-nonfree-rawhide
  10. Rpmfusion-nonfree-updates
  11. Rpmfusion-nonfree-updates-testing
  12. Rpmfusion-free
  13. Rpmfusion-free-rawhide
  14. Mysql-community-source
  15. Extensiones de Gnome-shell
  16. TexStudio
  17. Livna para controladores de gráficos
Todos estos repositorios los reuní en archivo .zip que se puede descargar desde quí.
Una vez descargado los archivos, se debe descomprimir y copiar los archivos a la ruta /etc/yum.repos.d despues actualizar con el comando:

sudo dnf -y update
Y finalizada la actuliazación de repositorios, ya pueden instalar sus aplicaciones.

Para deshabilitar un repositorio:

sudo yum-config-manager --disable repository

O bien se puede hacer de modo manual, ir a la ruta /etc/yum.repos.d abrir el repo con gedit:

sudo gedit nombre-repositorio.repo
Y marcar con 0 la línea que dice: enabled=1

Con estos archivos ya se puede descargar JDK, VLC, GOOGLE CHROME, MYSQL, VIRTUALBOX, TEXSTUDIO Y MUCHOS MÁS.


4 comentarios:

  1. hablando de repositorios, instalé un programa llamado Atom, es como el sublimeText, pero al instalar el repositorio me mandó un mensaje el sistema que me decia algo asi como que ese repo era de terseros, de igual manera yo le dí en instalar. Pero al actualizar ese repositorio presisamente me marca un error en los paquetes polkit.subject y polkit.caller.

    Ya traté de desinstalar el repo y no puedo, lo hice así:

    cd etc/yum.repos.d/
    dnf remove _copr_helber-atom.repo

    y lo que me aparece es:

    langpacks: No languages are enabled
    Adding es to language list
    No hay coincidencias para el argumento: _copr_helber-atom.repo
    Error: No se han seleccionado paquetes para ser eliminados

    ayuda por favor.

    ResponderEliminar
    Respuestas
    1. Haber si entendí, el repositorio aún está instalado, ya que no lo quiere desinstalar el comando dnf correcto?
      Yo usualmente los repositorios no los desinstalo con dnf, sino solamente ir al directorio que dices, y luego

      sudo rm nombre.repo

      luego queda actualizarlo y listo. Pero claro, esto hará que el programa de atom, no se actualice de manera automática, fuera de ahí no hay problema. Intenta con eso y me dices.

      De hecho ya estoy descargando atom y lo probaré el fedora 22, haber qué pasa...

      Eliminar