sábado, 17 de septiembre de 2016

Qué hacer después de instalar Apricity OS




Ya que migré recientemente a Apricity, pues es necesario realizar algunas configuraciones básicas para lograr el máximo desempeño del SO o al menos en mi caso, lo hice para tener las mismas herramientas, software, configuración y estilos que en gnome con Fedora 24.

Actualizar el SO:
sudo pacman -Syu

Después de la actualización, reiniciar:
reboot

Instalar las librerías de compilación para desarrolladores:
sudo pacman -Sy base-devel
Seleccionar, todas las fuentes de instalación que presente el comando.

Instalar ZSH para motor de comandos:
sudo pacman -S zsh git gedit
git clone git://github.com/robbyrussell/oh-my-zsh.git ~/.oh-my-zsh
cp ~/.oh-my-zsh/templates/zshrc.zsh-template ~/.zshrc
cp ~/.zshrc ~/.zshrc.orig
sudo chsh -s /bin/zsh nombre_usuario
Cerrar sesión y volver a iniciar para que los cambios se apliquen.

Instalar Firefox Libre Office en Español, Nautilus, Evince, Brasero, Gnome Builder, Shotwell, Clipgrab, Geany, Gedit, Mplayer, Youtube-dl, Unetbootin, Pdfmod, Vlc, dconf-editor, gconf-editor, gparted, filezilla, audacity mediante el uso del comando Pacman:
sudo pacman -S firefox libreoffice-fresh-es nautilus evince brasero gnome-builder shotwell clipgrab geany gedit mplayer youtube-dl unetbootin pdfmod vlc dconf-editor gconf-editor gparted filezilla pinta audacity hunspell wget curl libdvdread libdvdnav lsdvd
Compresores de archivos:
sudo pacman -S xz bzip2 p7zip lbzip2 lrzip arj lzop cpio unrar

Mediante Yaourt sugiero: netbeans, yandex, sublime text 3, fritzing, ffmulticonverter, converseen, vokoscreen, dropbox, gnome-exe-thumbnailer, shotcut, dbeaver, android-studio:
yaourt -S netbeans
yaourt -S yandex-browser-beta
yaourt -S sublime-text-dev
yaourt -S fritzing
yaourt -S ffmulticonverter
yaourt -S converseen
yaourt -S vokoscreen
yaourt -S dropbox


yaourt -S gnome-exe-thumbnailer
yaourt -S shotcut
yaourt -S dbeaver
yaourt -S android-studio


Opcionales (o tal vez no):

Texlive y editor TexStudio:
sudo pacman -S python-pygments python-setuptools texstudio texlive-core texlive-bibtexextra texlive-fontsextra texlive-formatsextra texlive-games texlive-genericextra texlive-htmlxml texlive-humanities texlive-latexextra texlive-pictures texlive-plainextra texlive-pstricks texlive-publishers texlive-science
Utilerías adicionales
sudo pacman -S foremost  htop maxima ghex iftop ogmrip xournal umbrello ninja-ide  wxmaxima gnuplot

VirtualBox:
Gestor de creación de máquinas virtuales multiplataforma.
sudo pacman -S virtualbox
Aquí les presenta dos fuentes de instalación, seleccionar la segunda. A continuación es necesario añadir nuestro usuario al grupo de virtualbox con el siguiente comando:
sudo usermod -G vboxusers -a tu-nombre-usuario


Gestor de base de datos PostgreSQL y pgAdmin III:

Gesto de base de datos MariaDB:

Personalizar Gnome Shell:


Personalización del escritorio Gnome Extensiones, temas de iconos y gtk, cursores para gnome shell:








Hay casi infinitos paquetes disponibles para distros GNU/Linux.


17 comentarios:

  1. ¿como hago para instalar spotify? puedo usar el mismo comando yaourt -S spotify ? jejje

    ResponderEliminar
    Respuestas
    1. Así es... si no está con ese comando entonces prueba con pacman, pero si tampoco lo encuntra entonces no está disponible ... :D

      Eliminar
  2. Espero puedan ayudarme me aparece este error desde el primer comando
    sudo pacman -Syu (me arroja este msj)
    Sincronizando las bases de datos de los paquetes…
    error: no se pudo actualizar apricity-core (no se pudo bloquear la base de datos)
    error: no se pudo actualizar core (no se pudo bloquear la base de datos)
    error: no se pudo actualizar extra (no se pudo bloquear la base de datos)
    error: no se pudo actualizar multilib (no se pudo bloquear la base de datos)
    error: no se pudo actualizar community (no se pudo bloquear la base de datos)
    error: no se pudo sincronizar ninguna base de datos
    error: no se pudo iniciar la operación (no se pudo bloquear la base de datos)
    error: no se pudo bloquear la base de datos: El fichero ya existe
    si está seguro de que no se está ejecutando
    un administrador de paquetes, puede quitar /var/lib/pacman/db.lck

    Gracias!!

    ResponderEliminar
    Respuestas
    1. Buen día, gracias por el comentario, mira, la razón de eso es simple, hay otro gestor utilizandolo, en este acaso es el gestor de actualizaciones por defecto, mientras lo utiliza nadie más lo puede utilizar. Tienes dos opciones, una, esperar a que termine el otro proceso o renombrar la base de paquetes de la ruta, esto se hace con el comando

      sudo mv /var/lib/pacman/db.lck /var/lib/pacman/db.lck-bk

      y luego de eso, parar el proceso que está buscando actualizaciones, es más fácil, porque en la barra superior hay un ícono como de estrella indicando que busca actualizaciones, dale clic derecho y dale en salir.

      una vez finalizado eso, ahora sí, ejecuta tu comando de actualización y no deberá de haber probelmas

      suerte !!!!!!

      Eliminar
  3. Espero puedan ayudarme me aparece este error desde el primer comando
    sudo pacman -Syu (me arroja este msj)
    Sincronizando las bases de datos de los paquetes…
    error: no se pudo actualizar apricity-core (no se pudo bloquear la base de datos)
    error: no se pudo actualizar core (no se pudo bloquear la base de datos)
    error: no se pudo actualizar extra (no se pudo bloquear la base de datos)
    error: no se pudo actualizar multilib (no se pudo bloquear la base de datos)
    error: no se pudo actualizar community (no se pudo bloquear la base de datos)
    error: no se pudo sincronizar ninguna base de datos
    error: no se pudo iniciar la operación (no se pudo bloquear la base de datos)
    error: no se pudo bloquear la base de datos: El fichero ya existe
    si está seguro de que no se está ejecutando
    un administrador de paquetes, puede quitar /var/lib/pacman/db.lck

    Gracias!!

    ResponderEliminar
  4. Espero puedan ayudarme, este msj me aparece desde el primer comando

    Sincronizando las bases de datos de los paquetes…
    error: no se pudo actualizar apricity-core (no se pudo bloquear la base de datos)
    error: no se pudo actualizar core (no se pudo bloquear la base de datos)
    error: no se pudo actualizar extra (no se pudo bloquear la base de datos)
    error: no se pudo actualizar multilib (no se pudo bloquear la base de datos)
    error: no se pudo actualizar community (no se pudo bloquear la base de datos)
    error: no se pudo sincronizar ninguna base de datos
    error: no se pudo iniciar la operación (no se pudo bloquear la base de datos)
    error: no se pudo bloquear la base de datos: El fichero ya existe
    si está seguro de que no se está ejecutando
    un administrador de paquetes, puede quitar /var/lib/pacman/db.lck

    ResponderEliminar
  5. Hola, ayer acabo de instalar apricity OS y no lo he podido actualizar, ya que todas las veces que lo intento me sale este error

    http://prntscr.com/denfqk (por favor ver la imágen en el link)

    Me dice que estos archivos ya existen y por eso que no se puede instalar, en otra parte leí que debía eliminarlos manualmente para que funcionara, lo hice pero después el sistema operativo dejó de funcionar, entonces no sé que más puedo hacer... Ayuda!!!

    ResponderEliminar
    Respuestas
    1. sí, mira también mi pasó eso... yo no lo eliminé, lo que hice fue renombrar la carpeta en donde estaban esos archivos, y con eso ya me permitió actualizar... esto lo tienes que hacer antes de actualizar, ya que si los eliminas o los renombras y reinicias el so, entrará en error, porque dichas configuraciones son necesarias...

      Eliminar
    2. Otra pregunta, cómo le cambió el nombre a la carpeta? al menos no encuentro a simple vista alguna parte en que me dé la opción y lo otro, da igual el nombre que le de a la carpeta?

      Eliminar
    3. con este comando:
      sudo mv /etc/fonts /etc/fonts-bk

      Eliminar
    4. Muchas gracias! Ahora ya no me aparece ese error...
      Ahora me aparece lo siguiente: "error al invocar al gestor de descargas externo", si no es una cosa es lo otro :(
      Disculpa por molestar tanto, soy newbie en Linux, antes solamente había utilizado Ubuntu y Elementary OS pero no había tenido ningún problema.

      Eliminar
    5. No te preocupes, cuando se trata de una distro con arch, ya son otros niveles (por así decirlo)... te recomiendo volver a instalar, únicamente apricity reemplazando la instalación previa, para que los errores que haya no causen lios, te daría más opciones, pero como dices que eres nuevo, sería mucho más fácil reinstalar...

      fue un placer ayudarte...

      Eliminar
    6. La verdad no fue necesario reinstalar, ya pude solucionarlo, lo actualicé por la terminal (Ayer eso fue lo primero que hice y lo intenté varias veces, pero siempre tenía problemas, por eso ahora había optado por hacerlo con el Gestor que trae Apricity). Aunque ahora quizás donde solucioné mis problemas principales se instaló fácilmente por consola jeje. Gracias por tu tiempo, disculpa las molestias.

      Eliminar
    7. no lo estabas haciendo por la terminal?

      rayos, dí por hecho que lo estabas haciendo de ese modo, por eso te mandé los comandos, debí haber preguntado eso, o mejor debíste haber mencionado eso.

      pero, que bien que lo hayas podido solucionar...

      estamos en contacto..

      Eliminar
  6. No importa el nombre que yo que agregue??

    ResponderEliminar
    Respuestas
    1. no, si quieres agregale -bk al final del nombre, sin espacios, y en caso de que el sistema cuelgue, al menos tienes dichos archvivos, entras en modo texto al so y modificas el nombre..

      Eliminar